[stunnel-users] stunnel and Pegasus Mail

sawbona at flashmail.com sawbona at flashmail.com
Sat Dec 14 21:25:32 CET 2013


Hello:

I recently came across stunnel as a solution (THE solution) to Pegasus 
Mail 4.63 having some sort of incompatibility with SSL versions in use 
at gmx.de and xsmail.com mail services.

As I was absolutely unwilling to let go of my trusty PMailo, stunnel 
proved to be a godsend.   =-)

At first the problem was with xsmail only and after setting up stunnel 
everything went along perfectly well, no problems whatsoever.

Now, gmx.de is enforcing the use of SSL on ports 993, 995 and 465 
instead of 110, 25 and 143 so I edited my stunnel.conf accordingly.

---

;***********************************************************************
;Configured service
;***********************************************************************

;Pegasus Mail 
;SSL connections to XSMail's servers
;Reason: there's some incompat between PMail 4.63 and SSL - 01/11/2013

[xsmail-POP3-SSL]
client = yes
accept = 10995
connect = mail.messagingengine.com:995

[xsmail-smtp-SSL]
client = yes
accept = 10465
connect = mail.messagingengine.com:465

[xsmail-IMAP-SSL]
client = yes
accept = 10993
connect = mail.messagingengine.com:993

;Pegasus Mail 
;SSL connections to GMX's servers
;Reason: there's some incompat between PMail 4.63 and SSL - 01/11/2013

[gmx-POP3-SSL]
client = yes
accept = 10995
connect = pop.gmx.net:995

[gmx-smtp-SSL]
client = yes
accept = 10465
connect = mail.gmx.net:465

[gmx-IMAP-SSL]
client = yes
accept = 10993
connect = imap.gmx.net:993

---

The issue at hand is that stunnel in not working properly now.

This is the log file for a successful connection to xsmail:

---

2013.12.14 17:15:08 LOG5[500:284]: Service [xsmail-POP3-SSL] accepted 
connection from 127.0.0.1:1182

2013.12.14 17:15:08 LOG5[500:284]: connect_blocking: connected 
66.111.4.51:995

2013.12.14 17:15:08 LOG5[500:284]: Service [xsmail-POP3-SSL] connected 
remote server from 192.168.1.102:1183

2013.12.14 17:15:10 LOG5[500:284]: Connection closed: 58 byte(s) sent 
to SSL, 112 byte(s) sent to socket

---

And this is the log file for a (failed) connection to gmx:

---

2013.12.14 17:17:15 LOG5[500:452]: Service [xsmail-POP3-SSL] accepted 
connection from 127.0.0.1:1184

2013.12.14 17:17:15 LOG5[500:452]: connect_blocking: connected 
66.111.4.52:995

2013.12.14 17:17:15 LOG5[500:452]: Service [xsmail-POP3-SSL] connected 
remote server from 192.168.1.102:1185

2013.12.14 17:17:21 LOG5[500:452]: Connection closed: 36 byte(s) sent 
to SSL, 126 byte(s) sent to socket

---

The PMail trace is this as follows:

[*] Connection established to 127.0.0.1
>> 0016 +OK POP3 ready
<< 0015 USER 14067985
>> 0005 +OK
<< 0015 PASS XXXXXXXX
>> 0083 -ERR You must use your full username of the form 
yourusername at domain.tld to login

Figures ...
It is attempting to connect to gmx with xsmail credentials.

As youcan see, for some strange reason it is connecting to gmx with 
xsmail settings.

Must be a *.conf file problem but I am at a loss as to what is gong on
Any ideas?

Thanks in advance,

CIV




More information about the stunnel-users mailing list