[stunnel-users] Newbie: Success, now failure???

Roger Bohl (Sr.) rhbohl at gmail.com
Wed Jul 25 20:28:03 CEST 2012

For several days, I've been using Stunnel (with Blat) successfully
(possibly with no intervening re-boots).

A day or so ago, the system was re booted

Today, however, Stunnel failed.  I got the following Stunnel reply message:

No limit detected for the number of clients
stunnel 4.53 on x86-pc-mingw32-gnu platform
Compiled/running with OpenSSL 0.9.8s-fips 4 Jan 2012
Threading:WIN32 SSL:+ENGINE+OCSP+FIPS Auth:none Sockets:SELECT+IPv6
Reading configuration from file stunnel.conf
FIPS mode is enabled
Compression not enabled
Snagged 64 random bytes from .rnd
Wrote 1024 new random bytes to .rnd
PRNG seeded successfully
Initializing inetd mode configuration
Certificate: client.pem
Certificate loaded
Key file: client.pem
Private key loaded
SSL options set: 0x00000004
Accept option is not allowed in inetd mode
Remove accept option or define a [section]

Server is down

The stunnel.conf file in the Stunnel directory is:

          CAfile = cert.pem
cert = client.pem
client = yes
RNDfile = .rnd

[gmail smtp]       ; (I may have had this in or out before.  In "cleaning
up" various files, I may have thought this to be a comment, and removed it.)
accept = 25
connect =  smtp.gmail.com:465

The program fails both with and without the [gmail smtp] line included.
Except, possibly, for removing ;[comment] lines, no other changes occurred.

Can somebody give me a clue as to the cause, and suggest the fix.  I'm
running Windows Vista.
(I found the 17+ page instruction file, by Michal Trojnara, but didn't see
a solution, there.)


Roger Bohl
rhbohl at gmail.com
707-939-8459 PDT
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20120725/4f926c13/attachment.html>

More information about the stunnel-users mailing list