[stunnel-users] WCE 3.0 run-time error, how to work around it?

Bao, Robert rbao at tycoint.com
Wed Dec 12 20:10:34 CET 2012

Hi Pierre,


To answer your questions first:

Target CPU: Motorola Power PC. Note: PPC is only supported in WCE 3.0 or lower :(

SDK 4.2: No

Tested on WM6 emulator: No

Using your tools: Indirectly. I worked around the build by using _X86_ compile define, and I credit it to you.



Note: the 4.34 version compiles/links/runs fine for PPC/WCE 3.0. I guess the run-time error for 5.0 was resulted from Mike’s using Winsock2/IPv6 starting in some version a while ago, and WCE 3.0 doesn’t support it!


Hope I answered your question, and thanks for your reply.




From: Pierre [mailto:delaage.pierre at free.fr] 
Sent: Wednesday, December 12, 2012 12:57 PM
To: Bao, Robert
Cc: <stunnel-users at stunnel.org>
Subject: Re: [stunnel-users] WCE 3.0 run-time error, how to work around it?


Hi Robert,


We are currently working. with Mike on next 500 wce port. there are some files and scripts modified for various targets x86, armv4...


i have compiled a working version but having a run timebug "commandbar-insermenubar error 120 only works in w32 mode"...and nothing displayed in log window...well it s on progress.


maybe your pb comes from the fact that v500 expects openssl 101c and 434 was built, by me (see my web page) with my openssl v100a port...


what is your target cpu ?

are you using sdk 4.2?

tested on wm6 emulator ?

are you using my mywcemake armv4 command line tool?


let us exchange some experience, but please be patient if you want to get my new wce openssl 101c or above and stunnel.5




Le 12 déc. 2012 à 18:19, "Bao, Robert" <rbao at tycoint.com> a écrit :



	The stunnel version used in our current product is 4.34. It worked well under Windows CE 3.0 and 5.0.


	However I got run-time error for 5.00 beta version under WCE 3.0 (even though I disabled IPv6, took out winsock2.h/ws2tcpip.h, included winsock.h, defined “struct addrinfo”, etc ).


	The error is: Error detected on SSL (read) file descriptor: Bad protocol option (WSAENOPROTOOPT) (10042)


	What else I need to do to resolve or work around it?


	Thank you.


	Robert Bao

	Software House

	Tyco International


	stunnel-users mailing list
	stunnel-users at stunnel.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20121212/e9d1254a/attachment.html>

More information about the stunnel-users mailing list