[stunnel-users] Getting Stunnel to Work Under Windows 7 64-bit

Thomas Eifert kxkvi at wi.rr.com
Sun Apr 29 00:06:53 CEST 2012

In my previous post, I neglected to include a relevant snippet from my 
stunnel.conf file.

Here it is:

debug = 6
fips = no
delay = yes
output = stunnel.log

client = yes
options = NO_SSLv2
sslVersion = TLSv1
cafile = peer-nntps.1.pem
verify = 4
accept =
connect = xxx.xxx.xxx.xxx:563

On 4/28/2012 4:38 PM, Thomas Eifert wrote:
> For the benefit of the group, I thought I'd share some experiences I 
> had when attempting to get
> Stunnel to run under Windows 7 SP1 64-bit.
> I initially installed Stunnel version 4.53 to the default location, 
> which in Windows 7 64-bit is:
> C:\Program Files (x86)\stunnel\
> I installed the service from the start menu option, then rebooted my 
> machine.
> I have administrator rights, and User Account Control is disabled.  My 
> observations
> included the following:
> 1.  The Stunnel status window displayed only configuration loads.  No 
> output from any
>       active connection was ever displayed, despite the fact that 
> Stunnel was passing
>       traffic to/from SSL-enabled servers.
> 2.  Stunnel would not write to the log file.  The error message 
> indicated that Stunnel was
>       unable to open stunnel.log.  Initially, I thought this might be 
> a factor in the lack of
>       status window connection output, so I commented the log 
> statement out to eliminate it.
>       I then reloaded the configuration.  The issue of not seeing any 
> connection info
>       was unaffected.
> 3.  The notification area icon would not appear on Stunnel service 
> load.  It would mysteriously
>       appear, then disappear, at seemingly random times.
> 4.  Once the service was installed, it was not possible to stop it or 
> uninstall it from the
>       provided start menu shortcuts.  Whenever I attempted to do so, 
> the Stunnel status
>       window would appear.  However, I was able to perform these 
> actions successfully by
>       opening a command prompt, then issuing the commands from there.
> In an effort to unravel these issues, I tried the following workarounds:
> 1.  I re-installed stunnel to a non-system controlled directory.  In 
> my case, it was C:\Apps\stunnel\.
>  2. I attempted to run stunnel in compatibility mode, set for Windows 
> XP SP3.
>  3. I tried installing 2 previous versions of Stunnel.
> All combinations produced exactly the same undesired result.
> Finally, I stopped and uninstalled the service.  Instead of using that 
> method, I created a
> shortcut to stunnel.exe, and placed it in the start menu's startup 
> folder, then rebooted.
> Stunnel started at boot time, and all of the above issues were resolved.
> As such, it seems like Stunnel just doesn't like to be run as a 
> service on a Windows 7 64-bit
> machine; at least not on the one I own.
> If you're encountering any stability issues with the Stunnel service 
> in the Windows 7 64-bit
> environment, try my method.  It works.
> I'd like to extend a special thank you to Carter Browne, who provided 
> valuable input throughout
> the course of my testing.
> Regards,
> Thomas

Attention: This message and all attachments are private and may contain information that is confidential and privileged. If you received this message in error, please notify the sender by reply email and delete the message immediately.

More information about the stunnel-users mailing list