[stunnel-users] stunnel v4.32 & mac v10.6.3

Cherry Ngai cherryn at gmail.com
Sat Sep 25 02:26:37 CEST 2010


I am new to stunnel.  My stunnel v4.32 is installed to my mac v10.6.3 using
MacPort.  I am trying to setup active directory, but there is no process
start when i run

sudo /opt/local/bin/stunnel /opt/local/etc/stunnel/stunnel.conf

There is no error msg after i run the command.  I believe it could have
something to do with my configuration?  Having it running in debug mode, I
can't find the created output file.  Could someone help me?  Or tell me
where i can find the output file?  Thanks!

Stunnel seems successfully installed, as it has returned the following with
the command "sudo stunnel -version"
stunnel 4.32 on i686-apple-darwin10.3.0 with OpenSSL 1.0.0a 1 Jun 2010

Global options
debug           = daemon.notice
pid             = /opt/local/var/run/stunnel/stunnel.pid
RNDbytes        = 64
RNDfile         = /dev/urandom
RNDoverwrite    = yes

Service-level options
cert            = /opt/local/etc/stunnel/stunnel.pem
ciphers         = ALL:!aNULL:!eNULL:!SSLv2
session         = 300 seconds
stack           = 65536 bytes
sslVersion      = SSLv3 for client, all for server
TIMEOUTbusy     = 300 seconds
TIMEOUTclose    = 60 seconds
TIMEOUTconnect  = 10 seconds
TIMEOUTidle     = 43200 seconds
verify          = none

Here is my config:
cert = /opt/local/etc/stunnel/stunnel.pem
key = /opt/local/etc/stunnel/stunnel.pem

sslVersion = SSLv3

chroot = /opt/local/var/lib/stunnel/
setuid = nobody
setgid = nogroup
pid = /stunnel.pid

socket = l:TCP_NODELAY=1
socket = r:TCP_NODELAY=1

debug = 7
output = stunnel.log

client = yes

accept = 391
connect = SOME_IP:636

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20100924/66d33b2f/attachment.html>

More information about the stunnel-users mailing list