[stunnel-users] How do you configure Stunnel Ver 4.31 for TLSv1

David M. Douglass david at az-douglass.net
Thu Feb 25 19:05:49 CET 2010

I am using the Windows Binary of Version 4.31, and an external email utility
that sends SMTP outgoing email.

I can configure for specific ports (no problem). and I can send SSMTP
SSLv3   with success.  That is GOOD !


I am trying to configure Stunnel for sending  TLSv1      without success. 

I understand (via the Version command and screen) that Stunnel defaults to

How do I change that to TLSv1 ??


I found the parameter :    

sslVersion = version

select version of SSL protocol

Allowed options: all, SSLv2, SSLv3, TLSv1


This appears to be a "SERVICE LEVEL" option, and I have tried to use the

sslVersion = TLSv1


in the [SSMTP] group of options (along with accept =  and  connect = ), but
get an error message in the log file, which is shown next:

2010.02.25 10:35:44 LOG3[2696:2740]: SSL_connect: 1408F10B:
error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number


I have also tried to put the   sslVersion =   line  in the general
configuration area, but generate the same error message.

The outbound email does, in fact, fail. 


Can anyone suggest what I am doing wrong ??   Or offer a solution for
configuring Stunnel (V4.31) for TLSv1 ??


David M. Douglass

david at az-douglass.net

Home (480) 839-2629

Cell (602) 908-9092


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20100225/c398d0e3/attachment.html>

More information about the stunnel-users mailing list