[stunnel-users] Problem with Stunnel and OpenBSD

Juan J. Martínez reidrac at usebox.net
Sat May 24 19:16:00 CEST 2008

> [...]
> 2- Then it stalls at:
> 2008.05.23 10:47:29 LOG7[16334:0]: SSL state (accept): before/accept
> initialization
> 3- After 3 minutes aprox, it continues and then it connects to popa3d
> and the mail is retrieved as expected.
> [...]


I think the problem it's not related to stunnel.

I've compiled it with debug support and using gdb I've debugged the
program while being stalled.

#0  0x0193571d in poll () from /usr/lib/libc.so.38.2
#1  0x1c00ac84 in s_poll_wait (fds=0x8964b310, sec=300, msec=0) at
#2  0x1c00453c in init_ssl (c=0x89643000) at
#3  0x1c00410d in do_client (c=0x89643000) at

The call to poll is correct at this point:

(gdb) p fds->nfds
$1 = 1
(gdb) p fds->ufds[0]
$2 = {fd = 8, events = 1, revents = 0}

And after reading the stunnel source for some time, all seems OK.

So I though again it *seems* a network problem (the poll in the server
stalls with the client writing, but the read queue in the server is
empty for that socket).

I tried to switch off the firewall again and... just because I'm
clueless, I tried changing the server port to a non standard one: it
works like a charm, without that 3 minutes delay.

The server it's in my home server, using a residential internet
connection from a spanish provider (ONO), and there's some hype with
this ISP regarding traffic limitation for P2P applications.

I don't know what is happening here, but changing the port has out, and
stunnel it's innocent.



desarrollo y sistemas: http://www.usebox.net/
      página personal: http://www.usebox.net/jjm/

More information about the stunnel-users mailing list