[stunnel-users] Stunnel message about SSL_shutdown/SSL_get_error

Lachance, Mario Mario.Lachance at emergis.com
Fri Aug 3 21:16:29 CEST 2007



I have been using openssl_0.9.7g and stunnel_4.10 on Solaris 9 without problem for 2 years in a production environment.


I want to upgrade to openssl_0.9.8e and stunnel_4.20 on solaris 10.


I have done some test on a development system and I have seen a new message in stunnel log file.


Old message with openssl_0.9.7g and stunnel_4.10 on Solaris 9  was :

Aug  3 14:51:58 solario stunnel[345]: [ID 702911 local6.notice] Too many retries on SSL shutdown


New message with openssl_0.9.8e and stunnel_4.20 on solaris 10 is :

Aug  3 14:42:30 daprxuu stunnel: [ID 821868 local6.error] LOG3[20957:4]: SSL_shutdown/SSL_get_error returned 6


I don't know if this new message has replaced the old one I was getting.


Can someone tell me what is behind this message "_shutdown/SSL_get_error returned 6"?


Please note that I am able to transfer message with both system (stunnel 4.10 and stunnel 4.20) from a windows client without any apparent problem.


Thank you for your help,












Avis de confidentialité: Ce message est confidentiel, protégé par le secret professionnel et à l'usage exclusif du destinataire. Toute autre personne est avisée qu'il lui est strictement interdit de le diffuser, distribuer ou reproduire. Si vous avez reçu ce message par erreur, avisez-nous immédiatement par téléphone et effacez toute copie.

Confidentiality Notice: This e-mail is confidential, privileged and intended for the exclusive use of the addressee. Any other person is strictly prohibited from disclosing, distributing or reproducing it. If you have received this e-mail by mistake, please notify us immediately by telephone and delete all copies. 



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20070803/1dc7abc3/attachment.html>

More information about the stunnel-users mailing list