[stunnel-users] Error when I try adding compression to stunnel.conf

Rami Michael thikrat at gmail.com
Tue Nov 14 05:18:46 CET 2006

Hey everyone,

I was going through the stunnel FAQ when I noticed you could add
compression.  I was very excited and wanted to give it a try but when I
tried to add

compression = zlib

to my stunnel.cong I got this error when starting stunnel...

Starting stunnel: file /etc/stunnel/stunnel.conf line 10: Specified option
name is not valid here

Line 10 is the exact place where i stuck this name value pair.  I don't know
where else i could put it, i tried putting it everywhere!

All requested info for posts to the group are found below

Here is my stunnel.conf

verify = 3
CAfile = /etc/stunnel/certs.pem
cert = /etc/stunnel/stunnel.pem
setuid = nobody
setgid = nobody
pid = /tmp/stunnel.pid
debug = 7
output = /var/log/stunnel.log
client = no
compression = zlib
accept  = 3309
connect = 3306

I am using centOS and installed stunnel and openssl via the available rpms,
using yum.  zlib is installed as well, but i don't think this is a zlib
issue, it seems like it just doesn't like "compression".  Was compression
added in a version later than 4.05?  Am i missing something incredinbly

Some output from the stunnel.log at high debug level

2006.11.13 23:03:10 LOG5[32244:3086689984]: stunnel 4.05 on
i686-redhat-linux-gnu PTHREAD+LIBWRAP with OpenSSL 0.9.7a Feb 19 2003
2006.11.13 23:03:10 LOG7[32244:3086689984]: Snagged 64 random bytes from
2006.11.13 23:03:10 LOG7[32244:3086689984]: RAND_status claims sufficient
entropy for the PRNG
2006.11.13 23:03:10 LOG6[32244:3086689984]: PRNG seeded successfully
2006.11.13 23:03:10 LOG7[32244:3086689984]: Certificate:
2006.11.13 23:03:10 LOG7[32244:3086689984]: Key file:
2006.11.13 23:03:10 LOG7[32244:3086689984]: Loaded verify certificates from
2006.11.13 23:03:10 LOG5[32244:3086689984]: FD_SETSIZE=1024, file
ulimit=1024 -> 500 clients allowed
2006.11.13 23:03:10 LOG7[32244:3086689984]: FD 4 in non-blocking mode
2006.11.13 23:03:10 LOG7[32244:3086689984]: SO_REUSEADDR option set on
accept socket
2006.11.13 23:03:10 LOG7[32244:3086689984]: mysqls bound to
2006.11.13 23:03:10 LOG7[32244:3086689984]: FD 5 in non-blocking mode
2006.11.13 23:03:10 LOG7[32244:3086689984]: FD 6 in non-blocking mode
2006.11.13 23:03:10 LOG7[32245:3086689984]: Created pid file

stunnel -V
2006.11.13 23:03:14 LOG3[32248:3086505664]: -V: No such file or directory

stunnel [filename] | -fd [n] | -help | -version | -sockets
    filename    - use specified config file instead of
    -fd n       - read the config file from specified file descriptor
    -help       - get config file help
    -version    - display version and defaults
    -sockets    - display default socket options

uname -a
Linux ramison 2.6.9-42.0.3.EL #1 Fri Oct 6 05:59:54 CDT 2006 i686 i686 i386

gcc -v
Reading specs from /usr/lib/gcc/i386-redhat-linux/3.4.6/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man
--infodir=/usr/share/info --enable-shared --enable-threads=posix
--disable-checking --with-system-zlib --enable-__cxa_atexit
--disable-libunwind-exceptions --enable-java-awt=gtk
Thread model: posix
gcc version 3.4.6 20060404 (Red Hat 3.4.6-3)

openssl version
OpenSSL 0.9.7a Feb 19 2003
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20061113/fe5e39cc/attachment.html>

More information about the stunnel-users mailing list