[stunnel-users] SSL2Proxy

Steve Cohen stunnelhelp at gmail.com
Thu May 11 23:46:20 CEST 2006

Hello all,

I'm tyring to get around content based(notHostBased) int*rn*t cen$0ring.
(don't want this page to be indexed with that keyword, so please don't wite
it in your response).
This is what I need to do:
Set Browser on client machine to use <proxyX:port>, but I want content to be
encrypted. The proxy is trusted(ownedByMe), everything else in between is
not, after the proxy everything is trusted.

So this would be the setup:
SetupA: ClientBroswer <> STunnelOnRemoteServer <>
LocalProxyServerOnSameServer(Squid) <> RestOfTheInternet

And NOT this:
SetupB: Browser<>LocalSTunnel<>RemoteSTunnel<>Proxy<>RestOfTheInternet
Because I don't want any special kind of configuration on the client's local
machine except for setting the proxy.(I am currently doing this via ssh

-I have squid running on remote server listening on 3128 and it works
-I have stunnel running on remote server listening on 8686 and forwarding to
-I have Firefox set to use <myServer:8686> as proxy
But when trying to use it, Firefox says connection reset....

Please tell me why this is happening and what I need to do.
Feel free to make any suggestions you want, I won't be annoyed if you tell
me something I already know.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20060512/9fee2352/attachment.html>

More information about the stunnel-users mailing list