[stunnel-users] stunnel use with TLS

Nadav, Erez Erez.Nadav at verint.com
Mon May 8 18:10:23 CEST 2006

Hi all,

1.	Can I use stunnel as a client which connects in TLS protocol ?
2.	I am using Stunnel 4.14 in client mode and trying to connect in
TLS protocol to certain server. The connection failed with the following
log file:

2006.05.03 10:42:52 LOG7[2388:1756]: connect_wait: waiting 10 seconds

2006.05.03 10:42:52 LOG7[2388:1756]: connect_wait: connected

2006.05.03 10:42:52 LOG7[2388:1756]: Remote FD=244 initialized

2006.05.03 10:42:52 LOG7[2388:1756]: TCP_NODELAY option set on remote

2006.05.03 10:42:52 LOG7[2388:1756]: SSL state (connect): before/connect

2006.05.03 10:42:52 LOG7[2388:1756]: SSL state (connect): SSLv3 write
client hello A

2006.05.03 10:42:52 LOG7[2388:1756]: SSL alert (write): fatal: handshake

2006.05.03 10:42:52 LOG3[2388:1756]: SSL_connect: 1408F10B:
error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

I had tried to configure stunnel configuration file with options =
NO_SSLv3, but nothing changed.

Did I miss anything ?

Can anybody help ?


Nadav Erez


Verint Systems Ltd.

Phone: +972-9-962-4753

Cell: +972-54-778-4753

Email: erez.nadav at verint.com <mailto:erez.nadav at erez.nadav@verint.com>

Web: www.verint.com <http://www.verint.com/>

This electronic message contains information from Verint Systems, which may be privileged and confidential.
The information is intended to be for the use of the individual(s)or entity named above.
If you are not the intended recipient, be aware that any disclosure, copying, distribution or use of the contents of this information is prohibited.
If you have received this electronic message in error, please notify us by replying to this email (1).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stunnel.org/pipermail/stunnel-users/attachments/20060508/bd6affe9/attachment.html>

More information about the stunnel-users mailing list