[stunnel-users] Problem with multiple stunnel jobs

Michal Trojnara Michal.Trojnara at mobi-com.net
Tue Jun 17 22:40:35 CEST 2008


Please try:
and let us know if it works for you.

Best regards,

On 2008-06-17, at 18:34, Carter Browne wrote:
> A couple of days ago, I upgrade from 4.15 to 4.23 on a Linux system
> running Redhat 8.  At the same time I went from openssl 0.9.8g to
> 0.9.8h.  No changes were made to the configuration file.  After the
> change, rather than starting a single process, it starts 6 processes.
> The process number of the lowest number process is the one that is put
> into the
> /var/run/stunnel.pid file.  When I try to stop stunnel, using
> /etc/init.d/stunnel stop, the lowest number process is kill, and the
> highest number process seems to be running
> continuously - although it is not a hard cpu loop, but it keeps on
> accumulating run time.
> The number of processes may not be a new phenomenon, but the inability
> to kill itself is.  I normally restart the stunnel on a daily basis to
> keep the log files manageable, but with this
> new behavior, the /etc/init.d/strunnel restart command fails because 
> the
> ports are still in use.
> Any ideas on how to fix this problem.
> Thanks,
> Carter
> -- 
> Carter Browne
> cbrowne at cbcs-usa.com
> 781-721-2890
> _______________________________________________
> stunnel-users mailing list
> stunnel-users at mirt.net
> http://stunnel.mirt.net/mailman/listinfo/stunnel-users

More information about the stunnel-users mailing list